Flexpa - Issue with Link – Incident details

Issue with Link

Resolved
Partial outage
Started 8 months agoLasted 26 minutes

Affected

link.flexpa.com

Partial outage from 6:54 PM to 7:20 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    Why did it happen?
    Flexpa released a fix to accommodate a scenario where some payer authentication flows were incompatible with Safari. However the fix, which uses cookies to handle communication between Flexpa Link and Flexpa API, introduced a bug which was undetectable in the development environment because the development environment shares the same domain across services.

    How do we prevent it in the future?

    • Broaden test suite across browsers. Safari, Chrome, Firefox etc.
    • Test across multiple domains in the development environment
  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are currently investigating this incident.