Flexpa - Issue with API – Incident details

Issue with API

Resolved
Major outage
Started 10 months agoLasted 44 minutes

Affected

api.flexpa.com

Major outage from 7:14 PM to 7:58 PM

link.flexpa.com

Major outage from 7:14 PM to 7:58 PM

my.flexpa.com

Major outage from 7:14 PM to 7:58 PM

flexpa.com/docs

Major outage from 7:14 PM to 7:58 PM

portal.flexpa.com

Major outage from 7:14 PM to 7:58 PM

Updates
  • Resolved
    Resolved

    We have resolved the issue with our API.

    The database cache our apps connect to was destroyed in the course of a configuration change today.

    This prevented a service from being online.

    That service being offline meant that every new Patient Access Token transitioned to an error state. An error state was shown visibly to patients / our customers and Links do not occur successfully.

    This impacted all customers (excepting those opted out from our data cache) because every new Patient Access Token requires this step to successfully complete.

    We completed resolution of this event once we had all applications pointed at the new data cache.

    Flexpa takes downtime such as this event seriously. We have completed a post-mortem procedure and will be introducing changes to our process to prevent this issue from re-occurring.

  • Investigating
    Investigating

    We are currently experiencing an issue processing patients. Patients will see an error during a patient link: "Patient Init".