Flexpa - Issue with API – Incident details

Issue with API

Resolved
Operational
Started 2 months agoLasted 28 minutes

Affected

api.flexpa.com

Major outage from 7:14 PM to 7:42 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    What happened?

    An update (migration) to our database took longer than expected and began to saturate connection resources. This resulted in services such as API not being able to make new connections.

    What are we doing to remediate?

    We are setting up increased monitoring in order to triage database connection issues faster. We are also optimizing our database lookups by using an index on the table that caused the issue.

  • Investigating
    Investigating
    We are currently investigating this incident.