Resolved
Stuck authorizations on Flexpa Link

Started
January 10, 2024 at 1:44 PM
Status
Resolved after 26 minutes

Impact

Operational
Affected
link.flexpa.com
  • Resolved
    Resolved

    This incident has been resolved. The incident impacted successful Flexpa Link authorizations.

    Why did it happen?
    We pushed a bug into production code related to the generation of system Patient IDs upon a successful Flexpa Link authorization. Due to a test which passed incorrectly, the bad logic was not caught in development.

    How to prevent in future?
    By creating re-usable test fixtures, specifically as it relates to our patient authorization model, we can make it easier for developers to avoid writing false positive test cases.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating reports of stuck authorizations on Flexpa Link.