Resolved
Issue with API

Started
August 18, 2023 at 2:35 PM
Status
Resolved after 4 minutes

Impact

Major outage
Affected
api.flexpa.com
link.flexpa.com
my.flexpa.com
flexpa.com/docs
portal.flexpa.com
  • Resolved

    This incident has been resolved. Post mortem summary:

    What happened?
    api.flexpa.com was unavailable and 503s were returning from the load balancer.

    Root cause analysis
    We tried to deploy a Task Definition that was pointing to secrets that were not in the parameter store, because those secrets were removed after the deploy was initiated.

    Action items to prevent its reoccurrence
    Ensure that removing a secret from Doppler should regenerate a task definition and redeploy.

  • Investigating

    We are currently investigating this incident.