Flexpa - Elevated 500 Responses – Incident details

Elevated 500 Responses

Resolved
Operational
Started about 1 month agoLasted 37 minutes

Affected

api.flexpa.com

Operational from 3:24 PM to 4:01 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We experienced a process failure during a routine database update, which caused some users to encounter errors when accessing the Flexpa API.

    Why did it happen?

    A database migration did not complete as expected, causing discrepancies between the application and the database. This was primarily due to the migration being prematurely stopped by our automated health checks.

    How to prevent it in the future?

    We are improving our deployment process to ensure that the application remains in a consistent state, even if a database update does not complete successfully. This change is intended to prevent similar errors from occurring in the future.

  • Investigating
    Investigating
    We are currently investigating this incident.