Flexpa - Issue with Link – Incident details

Issue with Link

Resolved
Operational
Started 9 months agoLasted 15 minutes

Affected

link.flexpa.com

Operational from 6:25 PM to 6:40 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    Why did it happen?
    The new parameter in Flexpa Link was checked if it was defined, and so the word "undefined" was being serialized into the Flexpa Link application state, and the application was crashing on this unexpected value.

    How do we prevent it in the future?

    • Include Flexpa Link (package) in our CICD test suites.
    • Implement a UX Monitoring alarm on MyFlexpa to test that Link is loading successful
  • Investigating
    Investigating

    We are currently investigating this incident.